[Ffmpeg-devel] cvs regression

Zoltan NAGY nagyz
Thu Jul 21 09:30:02 CEST 2005

Hans Zandbelt wrote:

> I tried your sdp file on my system (Linux i686
> and it works fine, opening 2 multicast sockets for RTP
> audio and video (netstat -apu, netstat -gn).
> It shows only a black window, but I assume that's normal
> when no steam comes in ;-)
well, thats the normal behaviour if no stream comes in, but anyway, here 
this does not work :)

> I used the latest ffmpeg CVS version.
> Can you specify what system and ffmpeg version you use?

well, latest ffmpeg cvs, and I have tried compiling it under debian 
with gcc-3.3, gcc-3.4 and gcc-4.01, and all behaved uncorrectly.

my kernel does _not_ have ipv6 support in it, as I'm not using it at 
here, work,
but libc and all libraries (so the system) has support for it...

well, the same message appears, if I try to ssh into a host with AAAA record
also set (not just A):
plazma3:/usr/src/linux# ssh nefty.hu
socket: Address family not supported by protocol

so, I think we should somehow detect that the connection cannot be made 
via ipv6,
and try it then in ipv4. I think the current code only tried ipv6, then 
if that was unsuccessfull,
then does not try connecting in ipv4.


Zoltan NAGY
Software Engineer

More information about the ffmpeg-devel mailing list