[Ffmpeg-devel] Visual studio .net problem

Martin Boehme boehme
Tue Oct 4 11:10:20 CEST 2005

Lucio Marcenaro wrote:
>> Hm... so you have them installed somewhere else on your search path? 
>> Otherwise, I'd say you aren't linking properly to the DLLs.
> i have ffmpeg stuff in my project dir:
> myprojectdir\
>     \include\ffmpeg
>     \lib (contains av*.lib)
>     \bin (contains av*.dll and .exe)
> then i add directory myprojectdir\include\ffmpeg and myprojectdir\lib in 
> visual studio options as additional directories for include and lib 
> files respectively

Have you tried copying the DLLs to the directory that contains your program?

You said in your other post that you deleted all of the FFmpeg libraries 
that you found on your system -- did that change anything?

Have you tried executing your own program after deleting all FFmpeg 
libraries (it should come up with some kind of error saying that it 
can't find the DLLs)? If that doesn't happen, it means that there's 
still some DLL lurking around somewhere...

>> Are your import libraries being generated correctly? Do you have the 
>> Microsoft link.exe on your path when you build FFmpeg, and do you see 
>> output from link.exe during the build process?
> i think so....
> i mean, if i run msys window and type link.exe it gives me
> Microsoft (R) Incremental Linker Version 7.10.3077
> Copyright (C) Microsoft Corporation.  All rights reserved.
> usage etc etc
> lib files are
> avcodec.lib (137.912 bytes)
> avformat.lib (188.028 bytes)
> avutil.lib (5.994 bytes)
> mingw make should generate lib dll and everything i need? is it correct?

That looks pretty OK...

> no need to run stuff like dlltool.exe manually, right?



Martin B?hme
Inst. f. Neuro- and Bioinformatics
Ratzeburger Allee 160, D-23538 Luebeck
Phone: +49 451 500 5514
Fax:   +49 451 500 5502
boehme at inb.uni-luebeck.de

More information about the ffmpeg-devel mailing list