[Ffmpeg-devel] libavcodec: possible QPEL decoding bug.

Marius the Mad marius_the_mad
Sat Sep 10 00:44:17 CEST 2005


My name is Mariusz Pociask. Milan Cutka, ffdshow developer, advised me
to tell libavcodec developers about the problem I encountered. I hope
I'm in the right place. :)

The story so far:

I was playing with XviD and had severe problems with image quality.
The picture was very noisy and muddy, similar to old MS MPEG4v2 encodes.
One of the last things I tried was changing ffdshow's XviD decoder from
libavcodec to XviD - and it improved things a lot.

What it looks like:

frame 154 from my sample, decoded by:

XviD: http://img39.imageshack.us/img39/3341/154xvid6xt.png
libavcodec: http://img39.imageshack.us/img39/4590/154avcodec2da.png

Frame 283:

XviD: http://img39.imageshack.us/img39/6135/283xvid3tg.png
libavcodec: http://img39.imageshack.us/img39/573/283avcodec5xl.png

I didn't use any postprocessing here (apart from YV12->RGB32
convertion during decoding).

My clip triggering this behaviour is available here (below 10 MB):

I know it was created using quite an old XviD build, but I used it after
I tried the latest CVS compile - and they both worked the same way.

Milan thinks it's a QPEL problem and I think he may be right - I tried
some other samples I created without QPEL and everything was OK.

It doesn't seem to be ffdshow's problem only, too - I tried it with VLC
and it exhibited the same behaviour.

It's my first post here - I hope it will turn out useful. :) If you need
some additional information, please let me know.

Best regards
Marius the Mad

mailto:marius_the_mad at epf.pl

12:12:41 AM

More information about the ffmpeg-devel mailing list