[Ffmpeg-devel] build systems

Sam Hocevar sam
Tue Sep 20 16:57:30 CEST 2005

On Tue, Sep 20, 2005, Michel Bardiaux wrote:

> *My* pet peeve with autotools is that if you want to work on some 
> project with its current CVS, you *must* have the autotools at the same 
> version as the rest of the developpers. That usually means a *very* 
> recent one. And that is usually incompatible with your distro.

   I do not believe that to be true. For the average project, any
version of automake from 1.6 (released q2 2002) and autoconf from 2.53
(released q1 2002) are sufficient. That is more than 3 years ago.

   More complicated projects usually require autoconf 2.59+ (q4 2003)
and libtool 1.5+ (q3 2003).

> It's as if ffmpeg required everyone to use *only* the most recent gcc.

   In fact, I do not know of any project that would specifically require
autotools more recent than year 2003, whereas many pieces of software
(including ffmpeg) can trigger countless gcc ICEs that require a gcc
upgrade or bugfix far more recent that 2003 (the latest example being
two days ago, requiring me to use gcc 4.1.0 to build a shared version of


More information about the ffmpeg-devel mailing list