[Ffmpeg-devel] build systems
Tue Sep 20 17:44:17 CEST 2005
Sam Hocevar wrote:
> On Tue, Sep 20, 2005, Michel Bardiaux wrote:
>>*My* pet peeve with autotools is that if you want to work on some
>>project with its current CVS, you *must* have the autotools at the same
>>version as the rest of the developpers. That usually means a *very*
>>recent one. And that is usually incompatible with your distro.
> I do not believe that to be true. For the average project, any
> version of automake from 1.6 (released q2 2002) and autoconf from 2.53
> (released q1 2002) are sufficient. That is more than 3 years ago.
> More complicated projects usually require autoconf 2.59+ (q4 2003)
> and libtool 1.5+ (q3 2003).
That's exactly why (well, *one* of the reasons) I stopped contributing
to Lesstif: it wanted 2.59, while with my debian woody (6 months ago) I
was stuck at 2.53. Every time the metaconfig files changed I had to ask
somebody to run the autotools for me!
For other projects, 2.53 works but sometimes prints some
incomprehensible and frightening messages. It *seems* to work, but how
to be sure?
The problem is, if ffmpeg were to go the autoway, it would be necessary
that anyone working on the metaconfig use exactly one and the same
version, to be sure some feature requiring some more recent autothing is
>>It's as if ffmpeg required everyone to use *only* the most recent gcc.
> In fact, I do not know of any project that would specifically require
> autotools more recent than year 2003, whereas many pieces of software
> (including ffmpeg) can trigger countless gcc ICEs that require a gcc
> upgrade or bugfix far more recent that 2003 (the latest example being
> two days ago, requiring me to use gcc 4.1.0 to build a shared version of
T +32  2 790 29 41
F +32  2 790 29 02
E mailto:mbardiaux at mediaxim.be
Vorstlaan 191 Boulevard du Souverain
Brussel 1160 Bruxelles
More information about the ffmpeg-devel