[Ffmpeg-devel] compilation error in mathematics.c

carboncopy public carboncopy.public
Tue Jan 17 06:13:37 CET 2006

I compile on Mac and I add in -DHAVE_LRINTF into my --extra-cflags, viz:


This is pass to the configure, viz :

./configure --extra-clags="-DHAVE_LRINTF"

Of course they are other flags which you might want to incorporate in
there. Just seprate the flags with a space and insert it where
appropriate, viz (mine):

--extra-cflags="-fast -I/opt/local/include -DHAVE_LRINTF -ftree-vectorize"

On 1/17/06, Ramesh Gupta <ramesh at guptas.net> wrote:
> Hi,
> Sorry if this sounds like a dumb question, or has been already
> answered elsewhere. I just checked out the latest head of ffmpeg from
> CVS, and tried to build it. Unfortunately, I ran into the following
> error:
> make -C libavutil all
> cc -O3 -g -Wall -Wno-switch  -no-cpp-precomp -pipe -fomit-frame-
> pointer -force_cpusubtype_ALL -Wno-sign-compare -faltivec -mdynamic-
> D_LARGEFILE_SOURCE -D_GNU_SOURCE  -c -o mathematics.o mathematics.c
> In file included from mathematics.c:24:
> common.h:579: error: static declaration of 'lrintf' follows non-
> static declaration
> make[1]: *** [mathematics.o] Error 1
> make: *** [lib] Error 2
> Is that a known problem, or might that be happening because of a
> problem in my environment? Thanks in advance.
> _______________________________________________
> ffmpeg-devel mailing list
> ffmpeg-devel at mplayerhq.hu
> http://mplayerhq.hu/mailman/listinfo/ffmpeg-devel

More information about the ffmpeg-devel mailing list