[Ffmpeg-devel] Strange problem with H.264 video in MPEG2 TS...

Luca Abeni lucabe72
Fri Jan 20 16:42:55 CET 2006

Hi M?ns,

On Fri, 2006-01-20 at 15:04 +0000, M?ns Rullg?rd wrote:
> > If you, instead, run
> > ./output_example source.avi
> > ./ffmpeg -i source.avi -vcodec h264 -f mpegts - | ./ffmpeg -i -
> > I'm pretty sure you'll see the problem too: I just did a cvs checkout
> > from scratch, so I certainly use the latest version :)
> I tried exactly that, and I still can't reproduce it.
I just realized that I was linking against the wrong x264 version (svn
from about 2 weeks ago)... After upgrading x264, the problem
I apologize for my error: I was so focused on checking the ffmpeg
version that I did fail in checking the x264 version. Sorry for wasting
your time.

So, summing up:
- ffmpeg from CVS with x264 from svn works
- ffmpeg from CVS with outdated (about 2 weeks old) x264 fails

I am still wondering why my workarond patch worked.

Copy this in your signature, if you think it is important:
                               N O    W A R ! ! !

 Email.it, the professional e-mail, gratis per te: http://www.email.it/f
 America, Africa, Australia, Asia...con Email Phone Card chiami ovunque spendendo meno di una telefonata interurbana
 Clicca qui: http://adv.email.it/cgi-bin/foclick.cgi?mid=2688&d=20-1

More information about the ffmpeg-devel mailing list