[Ffmpeg-devel] Strange problem with H.264 video in MPEG2 TS...

Måns Rullgård mru
Fri Jan 20 17:03:03 CET 2006

Luca Abeni said:
> Hi M?ns,
> On Fri, 2006-01-20 at 15:04 +0000, M?ns Rullg?rd wrote:
> [...]
>> > If you, instead, run
>> > ./output_example source.avi
>> > ./ffmpeg -i source.avi -vcodec h264 -f mpegts - | ./ffmpeg -i -
>> > I'm pretty sure you'll see the problem too: I just did a cvs checkout
>> > from scratch, so I certainly use the latest version :)
>> I tried exactly that, and I still can't reproduce it.
> I just realized that I was linking against the wrong x264 version (svn
> from about 2 weeks ago)... After upgrading x264, the problem
> disappeared.

Nice to know.

> I apologize for my error: I was so focused on checking the ffmpeg
> version that I did fail in checking the x264 version. Sorry for wasting
> your time.

No problem, slow day at work.

> So, summing up:
> - ffmpeg from CVS with x264 from svn works
> - ffmpeg from CVS with outdated (about 2 weeks old) x264 fails
> I am still wondering why my workarond patch worked.

The SEI message containing the x264 version apparently gets lost with reading
from a pipe in that manner.  This means that the frame rate encoding is
interpreted incorrectly (or the incorrect encoding is interpreted correctly).
It remains to figure out why packets are lost.

M?ns Rullg?rd
mru at inprovide.com

More information about the ffmpeg-devel mailing list