[Ffmpeg-devel] Re: mpeg4 file container

hannes h4nne5
Thu May 18 19:33:45 CEST 2006

hannes <h4nne5 <at> gmail.com> writes:

> hi!
> i have noticed that mp4 files created with ffmpeg build after february have
> problem playing in some players.
> I use ffmpeg -i 123.avi -vcodec mpeg4 -b 448 -acodec aac -ab 64 -f mp4 123.mp4
> for encoding.
> the files convert just fine, but there is something that prevents the files
> beeing played back. i had a look at the headers and noticed that the new ones
> that dont play contain "   ftypisom   mp41   wide ??mdat?  libfaac 1.24"
> while the old working ones would start with "   ftypisom   mp41 ?gmdat? 
> libfaac 1.24". i couldnt find any differences when looking at the files with
> file information tools like mediainfo.exe
> the files play fine in vlc and quicktime, they dont play in pvplayer or
> nintendo's play-yan.
> i used the builds i could find at http://ffdshow.faireal.net/mirror/ffmpeg/
> i uploaded everything to:
> www.formaji.com/old.exe -> ffmpeg downloaded ~february
> www.formaji.com/new.exe -> march ffmpeg, newer ones have the same problem
> www.formaji.com/old.mp4 -> old ffmpeg converted file
> www.formaji.com/new.mp4 -> you get it
> can someone give me a clue what was changed in the code? why do the converted
> files differ?
> also i tried compiling ffmpeg yesterday myself and it doesnt seem to work. at
> some point it allways gives me an error 1 and stops compiling, no matter what
> ./configuration i use. others experienced this?
> thanks
> hannes

sorry, please be patient as it?s the first time i use mingw msys and cvs.
ok, so i now got the latest cvs
i launched msys and if i run ffmpeg in msys it runs smoothly and files get
converted the way i want them to.
so now i would like to build an exe that works just like ffmpeg in msys.
i used ./configure with the exact same settings i see when running ffmpeg in
msys (--enable-theora --enable-mp3lame --enable-libogg --enable...)
then i launch "make" but it allways stops at some point with an error 2.
the only way i can "make" and "make install" is by only setting ./configure
--enable-memalign-hack --enable-mingw32, leaving out all the other stuff.
is there an easy way to compile ffmpeg binaries that work just the way ffmpeg
works under msys? or do i have to download lame cvs, xvid cvs; set flags and
what not...
excuse my inexperience

More information about the ffmpeg-devel mailing list