[Ffmpeg-devel] Dll's with MinGW

Matt Schuckmann mschuck
Tue May 30 17:25:17 CEST 2006

I ran into this a couple of weeks ago and I got the attached patch from
Diego Biurrun and it solved the problem by moving the .51 and .49 and .50 to
before the .lib and .dll. I think the problem is MS link doesn't know how to
deal with files that are .51 etc. 

Perhaps this patch never got applied to the CVS tree. 

Matt S. 

-----Original Message-----
From: ffmpeg-devel-bounces at mplayerhq.hu
[mailto:ffmpeg-devel-bounces at mplayerhq.hu] On Behalf Of lorenzk at gmx.net
Sent: Monday, May 29, 2006 2:57 PM
To: ffmpeg-devel at mplayerhq.hu
Subject: [Ffmpeg-devel] Dll's with MinGW


after searching the archives, I found other people's questions on avformat,
avcodec and avutil libraries under Windows/MinGW.

I did successfully ffmpeg and the libs, but I get these files:

The .51, .50, .49 files are binary identical to the .dll files.

avcodec.dll references (uses) avutil.dll.49.
avformat.dll references (uses) avutil.dll.49 and avcodec.dll.51.

Is this (using the .51, .50, .49 files) by intention?

When I look inside the lib files (with dumpbin.exe), I can see that there
are no public symbols exported, besides the standard ones:
__IMPORT_DESCRIPTOR_avcodec.dll (to me it looks like the ".dll" is wrong,
because we then need a DLL avcodec.dll.dll)
?avcodec.dll_NULL_THUNK_DATA (again ".dll" that shouldn't be here)

So it is no wonder that the libs cannot be used to automatically link
against the DLLs.

Please could somebody with insight shed a little light on this.


ffmpeg-devel mailing list
ffmpeg-devel at mplayerhq.hu
-------------- next part --------------
A non-text attachment was scrubbed...
Name: mingw_slib.patch
Type: application/octet-stream
Size: 632 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20060530/4a50fc38/attachment.obj>

More information about the ffmpeg-devel mailing list