[Ffmpeg-devel] Dll's with MinGW

Brian Brice bbrice
Tue May 30 19:13:58 CEST 2006

Matt Schuckmann wrote:
> I ran into this a couple of weeks ago and I got the attached patch from
> Diego Biurrun and it solved the problem by moving the .51 and .49 and .50 to
> before the .lib and .dll. I think the problem is MS link doesn't know how to
> deal with files that are .51 etc. 
> Perhaps this patch never got applied to the CVS tree. 
> Matt S. 

Something seems very wrong with the win32 build.  I've been trying to
look at the patches and I can't tell what it is.  Why is the version
number now included in the file name?  The version of the DLL without
the version number *depends* on the files with the version numbers.
Even building with enable-shared and disable-static produces a binary of
ffmpeg that doesn't seem to run.  At least on my system it produces this
when trying to execute it (after not complaining about the DLLs with the
version number missing):

ffmpeg.exe - Application Error
The application failed to initialize properly (0xc0000005). Click on OK
to terminate the application.

Specifying extra LDFLAGS still doesn't seem to work and I can't build
with lame support.

./configure \
	--enable-mingw32 \
	--disable-static \
	--enable-shared  \
	--enable-memalign-hack \
	--disable-debug \
	--enable-mp3lame \
	--extra-cflags=-I$LAME/include \
	--extra-ldflags=-L$LAME/lib \
	--prefix=$PREFIX \
	--incdir=$PREFIX/include \


gcc -shared -Wl,-soname,avutil.49.dll
-Wl,--output-def,avutil.49.def,--out-implib,libavutil.dll.a -o
avutil.49.dll mathematics.o rational.o intfloat_readwrite.o crc.o -lm
-lmp3lame -lz
cannot find -lmp3lame
collect2: ld returned 1 exit status
make[1]: *** [avutil.49.dll] Error 1
make[1]: Leaving directory `/home/bbrice/ffmpeg-20060530-src/libavutil'
make: *** [lib] Error 2

Brian Brice
In order to know recursion, you must first know recursion...

More information about the ffmpeg-devel mailing list