[Ffmpeg-devel] Problem with copying streams

Roman Langl lombarus
Wed May 31 14:48:18 CEST 2006

Hi there,

last month I tried to copy a part form a videofile using ffmpeg with the
options -i <input_filename> -acodec copy -vcodec copy -ss 00:09:00 -t
00:01:00, followed by the name of the outputfile, and it work great with
every inputfile I tried. In the meantime I had to reinstall my computer.
Now i tried it again, but just the mpeg1 file work correct. By all
others I get at least the "non monotone timestams" error. Other problems
are, that the output file has about 350 MB although the input file has
just 28 MB(and I just copy a piece of it), or the new generated video
does conatin the correct time info, means the length of the video is 10
minutes (see upper example) and not only one minute. Some video will
work if I don't set the option -vcodec, other when not using -acodec.
What I trie do is to copy some piece of video without de- and encoding
the file.

I built it the same way than last time using the --enable-share
--disable-static option. I installed all necessary codec. I checked out
the newest sourcecode and also tried my old one, both with the same

Does anyone has any idea what the problem could be?

Thank for help

Roman Langl

More information about the ffmpeg-devel mailing list