[Ffmpeg-devel] Mac OS X h264 playback broken?

Ryan Martell rdm4
Tue Oct 3 19:53:18 CEST 2006

So, I'm new to this list, so be kind.

Using my intel macbook, I was running the h264 decoder to play an  
ipod compatible video using ffplay.  This was working great.  So then  
I tried using the rtp streaming stuff to play back a video streamed  
via darwin streaming server.  This didn't work.  So I look at the  
code, realize that the h264 transport protocol isn't supported by the  
version of rtp in the library.  Great, so I write that code.  Then,  
just as I get everything mostly working, in a fit of madness, I check  
out all the latest code (overwriting my stuff, which was probably a  
month or so old).

Now when I play  h264 video file, it no longer works (this is without  
streaming).  No problem, I think- I broke something.  I check out a  
fresh new copy of the code, and get the same result- a black screen  
(audio is still working).  Various other videos yield the same  
result; all tested videos worked before.

Okay, so something is broken in the library, it's probably a  
byteswapping issue, because it works on my G4- right?

So I check out a fresh clean copy of ffmpeg, and compile it on the  
G4.  It runs and plays the video, but it is Blue.  My people look  
like Smurfs.  It appears that it is putting the YUV image directly to  
the screen, without converting it to RGB.  I look at the code, and it  
is using SDL YUV overlays.  Has anyone seen this?  Is it an FFMPEG  
issue or a SDL issue?

So, essentially, I have two problems:
1) h264 Video Playback is Broken on Intel MacBooks (Black Screen).
2) h264 Video Playback is Broken on Mac G4 (Appears that YUV image is  
being blitted to screen; or could be an endian issue).

The good news is, that if anyone can help me figure these two out, I  
can debug and post my h264 streaming via rtsp code, which is pretty  
clean and plays well with others... (Which I am testing against  
Darwin Streaming Server).

MacBook Pro: 1.84Ghz Dual Core, 10.4.8 (8L2127) (Prerelease)
PowerMac G4, Dual 1 GHz, 10.4.7

Thanks for any advice and/or pointers!

More information about the ffmpeg-devel mailing list