[Ffmpeg-devel] seek with duration for cutting: broken or changed?

Michael Niedermayer michaelni
Tue Oct 31 01:47:06 CET 2006


On Mon, Oct 30, 2006 at 05:37:25PM -0500, Cyrus A wrote:
> Michael Niedermayer wrote:
> >Hi
> >
> >On Mon, Oct 30, 2006 at 12:55:16PM -0500, Cyrus A wrote:
> >  
> >>The following command used to work to cut a specific segment out of a 
> >>video file on some FC3 machines I'm using with an old version of ffmpeg 
> >>(still does work):
> >>
> >>ffmpeg -acodec copy -vcodec copy -i fullvideo.avi -ss 60 -t 120 
> >>choppedvideo.avi
> >>
> >>But it doesn't work anymore with Fedora Core 5 on a 64-bit machine 
> >>running today's SVN copy of ffmpeg. (Also doesn't work with freshrpms 
> >>latest ffmpeg rpm, either.) I believe what it's doing is seeking, but 
> >>the duration is completely ignored. It just returns the rest of the file 
> >>from where the seek took it. The resulting file is also a little 
> >>"chirpy"  -- the audio video sync is messed up somehow.
> >>    
> >
> >could you find out when this problem was introduced into svn (see 
> >binary search and svn up -r)
> >
> >[...]
> >
> >  
> Found it. The seek + duration option worked normally through revision 
> 4526 and then stopped working in 4527 and every other revision 
> thereafter. It was August 15th, 2005.
> The change notes read:
> parse pict_type for streams in avi
> fix mpeg4 parser so it outputs te pict_type
> support header only parseing without repacking
> That's interesting since I'm using mpeg4 for my vcodec and producing an 
> AVI file.
> Man, binary searching like that is not fun. Please let me know what you 
> think.

i think ive just fixed it ...

Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

In the past you could go to a library and read, borrow or copy any book
Today you'd get arrested for mere telling someone where the library is

More information about the ffmpeg-devel mailing list