[Ffmpeg-devel] [BUG] MPEG 2 Division By Zero

Brian Brice bbrice
Tue Oct 31 21:25:34 CET 2006

Benjamin Larsson wrote:
> Brian Brice wrote:
>> M?ns Rullg?rd wrote:
>>> Brian Brice <bbrice at newtek.com> writes:
>>>> Brian Brice wrote:
>>>>> M?ns Rullg?rd wrote:
>>>>>> Brian Brice <bbrice at newtek.com> writes:
>>>>>>> Hello.
>>>>>>> Something quite strange is happening when I'm encoding MPEG 2.  I'm
>>>>>>> encoding clips that are just noise and I get "division by 0"
>>>>>>> crashes.
>>>>>>> Unforunately, I can't produce a call stack (using DLLs in Windows
>>>>>>> from
>>>>>>> VC++), but I did narrow down where the division is occurring:
>>>>>> Upload a sample and tell us an FFmpeg command line that reproduces
>>>>>> the
>>>>>> error.
>>>>> Unfortunately I'm not using the command line. :-(
>>>>> I am linking to the DLLs produced by mingw/gcc from within Visual
>>>>> Studio.  And I know it's not a VS problem (so don't bash, please?),
>>>>> because this stuff has worked before.  I am programmatically
>>>>> generating
>>>>> frames of noise and throwing them at the encoder.  I set only certain
>>>>> members of AVCodecContext (as mentioned in the first email), and leave
>>>>> the rest to default.
>>>> Sorry, I spoke too soon.  Right after I sent that message, I tried
>>>> making an uncompressed AVI with this noise then using ffmpeg on the
>>>> command line to reproduce.
>>>> I uploaded a sample to /MPlayer/incoming/VictoriasNoise
>>>> Here is a log of the execution:
>>> Does it crash?
>> Yes.  Unfortunately mingw/gdb doesn't give a good backtrace.  GDB:
>> (fyi, my ffmpeg binary isn't stripped)
>> pollux:~> gdb ./ffmpeg
> Do you have ffmpeg_g ?

I compiled with --disable-strip.  ffmpeg and ffmpeg_g are the same:
19f19f23abd49096b7a1eb1f80b62b79 *ffmpeg.exe
19f19f23abd49096b7a1eb1f80b62b79 *ffmpeg_g.exe

Brian Brice

More information about the ffmpeg-devel mailing list