[Ffmpeg-devel] FFServer and RTSP

Luca Abeni lucabe72
Thu Apr 5 19:51:00 CEST 2007


today I tried to use ffserver to stream a simple mpeg file via RTP. I
added the following lines to ffserver.conf:
<Stream test1-rtsp.mpg>
Format rtp
File "/tmp/test.mpg"

and then tried to receive rtsp://localhost:5454/test1-rtsp.mpg with a
simple RTSP client. ffserver answered with
200 Unknown Error
which looked very strange because 200 is the code for "OK"... This bug
is caused by commit 8254, which removed the "DEF()" macro used by
The attached patch fixes this specific bug. After applying it, ffserver
gives a correct response "200 OK", but it still does not work. I am
investigating this second problem.

So, I have a question: did anyone manage to correctly stream on-demand
RTP with ffserver? If yes, with which ffserver version?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: partly-fix-ffserver.diff
Type: text/x-patch
Size: 1334 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20070405/d42bc2f1/attachment.bin>

More information about the ffmpeg-devel mailing list