[Ffmpeg-devel] Changing "-vstats" option behaviour

Stefano Sabatini stefano.sabatini-lala
Tue Apr 17 16:25:13 CEST 2007


On date Tuesday 2007-04-17 14:34:55 +0200, Michael Niedermayer encoded:
> Hi
> On Tue, Apr 17, 2007 at 11:41:57AM +0200, Stefano Sabatini wrote:
> [...]
> > I changed the -vstats option name to -vstats_file, that seems clearer
> > and, being different from the previous option name, should also get
> > the change more apparent to the user that was used to the previous
> > behaviour.
> > 
> > I also changed the name of the function do_video_stats to do_vstats,
> > which seems to me more consistent with the rest of the code.
> renamings are cosmetic changes and MUST be seperate from functional changes

I consider the modification of the option name (-vstats -->
-vstats_file) part of the "functional" change which changes the option
meaning and the behaviour of the program, the new option name
reflecting that change.
I agree that the do_video_stats -> do_vstats renaming is a cosmetic
change, so it can eventually go into another commit.

In attachment there is the resulting diff. If that's OK I can add to
it a corresponding ffmpeg.1 manpage modification before to commit.

Kind regards.
Stefano Sabatini
Linux user number 337176 (see http://counter.li.org)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: vstats_file.diff
Type: text/x-diff
Size: 4531 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20070417/56c3b2a6/attachment.diff>

More information about the ffmpeg-devel mailing list