[Ffmpeg-devel] Modify ffplay for realtime playing

Phuoc Do pdo.cloud
Fri Apr 20 09:37:35 CEST 2007

I might be doing something wrong then. ffplay is not playing the streams
correctly. Here is my setting. On a remote machine, I run my test video
file: mpeg4 video 384 kbs and mp2 audio 64 kbs. I use VLC and encapsulate
the streams in ASF container format. VLC outputs the resulted stream to a
http address and port. On my local machine, I tried to use VLC and MPlayer
for playback. In both players, the stream stops playing after about 5
seconds. I then tried ffplay for playback. ffplay also stops after a few
seconds. I noticed that A-V value gets larger overtime. My remote machine
has a DSL connection and my local machine has a cable connection. I used
Wireshark to capture the network packets and it shows that some of the TCP
packets have wrong header information. That's why I am thinking that some
bits are flipped and try to figure a solution to make ffplay more error


On 4/19/07, Reimar Doeffinger <Reimar.Doeffinger at stud.uni-karlsruhe.de>
> Hello,
> On Thu, Apr 19, 2007 at 01:05:41PM -0700, Phuoc Do wrote:
> > Sorry for the wording. It's not packet loss but the received packets
> contain
> > error, e.g. bits got flipped. So the header is corrupted in some
> packets.
> That is not possible either with HTTP. Maybe you should try to read up
> on at least the basics of the stuff you are using...
> Greetings,
> Reimar Doeffinger
> _______________________________________________
> ffmpeg-devel mailing list
> ffmpeg-devel at mplayerhq.hu
> http://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-devel

More information about the ffmpeg-devel mailing list