[FFmpeg-devel] [PATCH] move cutils string functions to libavutil

Michael Niedermayer michaelni
Sat Jun 23 17:31:32 CEST 2007


On Sat, Jun 23, 2007 at 02:53:38PM +0200, Reimar D?ffinger wrote:
> Hello,
> On Sat, Jun 23, 2007 at 01:13:11PM +0100, M?ns Rullg?rd wrote:
> [...]
> > Can we also rename some of them using more intuitive names?  I would
> > suggest these:
> > 
> > strstart  -> av_strstart
> > stristart -> av_stristart
> > pstrcpy   -> av_strncpy
> > pstrcat   -> av_strncat
> Hmm... maybe av_strlcpy and av_strlcat is more intuitive? I think they are
> closer to how these functions work...

seconded, and maybe change the order of the parameters to match strl*() ?
but iam perfectly fine with keeping the order as is if mans prefers
iam also fine with moving these 4 to libavutil and giving them av_ prefixes
though id like to think a day or 2 about their API before making them
part of the official public API of libavutil

Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

Republics decline into democracies and democracies degenerate into
despotisms. -- Aristotle
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20070623/6447172b/attachment.pgp>

More information about the ffmpeg-devel mailing list