[FFmpeg-devel] [PATCH] ALSA for libavdevice

Luca Abeni lucabe72
Thu Dec 18 14:58:57 CET 2008

Luca Abeni wrote:
>> ok, if someone has tested both recording & playback (ideally with video) and
>> it worked (including AV sync)
> I tried to test the latest version, but it turns out that the alsa library
> installed on my machine does not provide SND_PCM_TSTAMP_ENABLE and
> snd_pcm_htimestamp(). I am on Ubuntu 8.04.1.
> Which version of the alsa library is needed?
> I am rebooting to a debian testing/unstable machine to see if it provides
> a good alsa library...

Ok; with debian unstable I've been able to compile the alsa input format,
but... It does not seem to work :(
	snd_pcm_htimestamp(s->h, &ts_delay, &timestamp);
blocks forever, hence ffmpeg hangs... I tried to investigate, and it seems
that the alsa library is spinning forever in something called

If I comment out the snd_pcm_htimestamp() call and I assing pts based on
av_gettime(), then everything seems to work properly.

The command line I used for testing is
	ffmpeg -f alsa -i default test.mp2

So, it seems to me that the alsa library is still not stable enough for
what concerns the snd_pcm_htimestamp() function. :(


More information about the ffmpeg-devel mailing list