[FFmpeg-devel] MainConcept mpeg not decoding properly.

Media Streaming Services mediastream
Fri Jan 11 18:03:05 CET 2008

Hi all.

I'm trying to encode mpg to 3gp and have problems with the source file.
Audio track is encoded as 140 seconds and video is 206 seconds...

I've tried uploading to mplayer's ftp, but the file gets deleted soon
after I finish uploading.

it's a MainConcept muxed mpeg2-ps. Plays fin in Windows graphedit&WMP using
Mainconcept demuxer.

I have tried -vcodec h264, -acodec liba52, -f mpeg, -f svd, -f dvd,
-async 1, -vsync 1... all produce bad files, asynch had actually
produced file with equal video and audio length, but audio got
"chopped up". Is it a bug? Or am I doing something wrong?

/usr/local/bin/ffmpeg -f dvd -vcodec h264 -i DA_117588fd522.mpg
-bitexact 1 -vcodec mpeg4 -deinterlace -s 176x144 -r 12 -b 92k -nr 1
-preme 1 -bt 100k  -lowres 1 -trell 1 -maxrate 110k -bufsize 256k -vol
400  -acodec libamr_nb -ac 1 -ar 8000 -ab 12.2k -y -pass 2 9.3gp

FFmpeg version SVN-r11028

Thank you.

More information about the ffmpeg-devel mailing list