[FFmpeg-devel] MainConcept mpeg not decoding properly.

Måns Rullgård mans
Fri Jan 11 22:53:44 CET 2008

"Media Streaming Services" <mediastream at gmail.com> writes:

> On Jan 11, 2008 12:47 PM, Mike Melanson <mike at multimedia.cx> wrote:
>> Media Streaming Services wrote:
>> > Hi all.
>> >
>> > I'm trying to encode mpg to 3gp and have problems with the source file.
>> > Audio track is encoded as 140 seconds and video is 206 seconds...
>> >
>> > http://rapidshare.com/files/82302675/DA_117588fd522.mpg.html
>> > I've tried uploading to mplayer's ftp, but the file gets deleted soon
>> > after I finish uploading.
> yes, that's my folder.
>> It's on the FTP, in a directory called Mainconcept_MPEG/. I would move
>> it to a visible area, but I'm not sure where it belongs.
>> > FFmpeg version SVN-r11028
>> How about the current version?
> I've updated to FFmpeg version SVN-r11508
> Still the same error: (note audio and video duration)

Quite a few frames are being repeated, for whatever reason.  If I
extract the video elementary stream and try to decode it alone, the
first two frames output are the same.  The third output frame is the
same as frame number 1999 (!) when decoding the MPEG file, which then
is the 1344th unique frame to be written.

Something strange is certainly going on here.  The Mainconcept
encoders are usually good (v2.0 and up, v1.x suck), so I'd be
surprised if the file is at fault.

M?ns Rullg?rd
mans at mansr.com

More information about the ffmpeg-devel mailing list