[FFmpeg-devel] QCELP Patch with FFMPEG

Zubin Singh Parihar zubinp
Wed Jan 23 19:14:38 CET 2008

I was wondering if anyone can point me in the right direction with compiling 
the QCELP patch with FFMPEG

I'm not sure what build to use, so far i've tried versions:

- SVN-r9728
- SVN-r11200
- SVN-r10890
- SVN-r7439

I downloaded 

and extracted it, then:

1. Copied the ffmpeg_diff/qcelp folder to /ffmpeg/libavcodec/

(The configure file in the top-level directory of ffmpeg_diff and the Makefile 
in the ffmpeg_diff/libavcodec directory are different from all the builds i 
tried, so i just edited those files in the builds...)

2. Copied the *.c *.h files in ffmpeg_diff/libavcodec to /ffmpeg/libavcodec
3. Copied the *.c files in ffmpeg_diff/libavformat to /ffmpeg/libavformat
4. Made changes to the /ffmpeg/configure file
5. Made changes to the /ffmpeg/libavcodec/Makefile
6. In the /ffmpeg directory, I ran: ./configure --enable-qcelp
7. After the configure script mentioned that QCELP would be compiled, i 
ran 'make'

But then it fails.  I don't believe my ffmpeg build is correct and 

I also found this page: 

But I didn't know exactly how to compile it...?  It doesn't say anything about 
editing the configure scripts.   I also went into the the qcelp directories 
and did a 'make' , and then continued on with a regular "configure, make, 
make install" in the ffmpeg top-level directory.  This didn't work either, 
just a wild "stab in the dark".

I would really like to get qcelp enabled in FFMPEG.  Any help to get it 
working would be appreciated!


Zubin Singh Parihar 

More information about the ffmpeg-devel mailing list