[FFmpeg-devel] [PATCH] GET_RL_VLC can hide function parameters
Tue Jul 22 19:25:40 CEST 2008
On Tue, Jul 22, 2008 at 07:14:32PM +0200, Reimar D?ffinger wrote:
> On Tue, Jul 22, 2008 at 09:10:22AM -0700, Erik Hovland wrote:
> > On Tue, Jul 22, 2008 at 04:24:49PM +0100, M?ns Rullg?rd wrote:
> > > >> Wouldn't it be better to change the GET_RL_VLC macro to use names less
> > > >> likely to clash?
> > > >
> > > > That is what the patch does. Is length too common as well?
> > >
> > > I'd be inclined to say yes.
> > Patch resubmitted with n changed to vlc_length.
> If the goal is to avoid clashes, this kind of change is simply
> pointless, and also doing it only to one variable is not that
> _If_ we want a proper fix for this, something like prefixing everything
> with e.g. get_rl_vlc_ or shorter grv_ should be quite reliable, but
> uglify the code.
> If a proper fix is not wanted, then the question is what we would
I was thinking about this on the way in to work. I will gladly submit a
patch which attempts to provide some crude namespace fixing if I could
get some advice on what sort of fixing would not be so ugly that it
wouldn't be accepted.
mail: erik at hovland.org
PGP/GPG public key available on request
More information about the ffmpeg-devel