[FFmpeg-devel] [PATCH] GET_RL_VLC can hide function parameters
Sat Jul 26 05:22:07 CEST 2008
On Tue, Jul 22, 2008 at 10:25:40AM -0700, Erik Hovland wrote:
> > If the goal is to avoid clashes, this kind of change is simply
> > pointless, and also doing it only to one variable is not that
> > helpful.
> > _If_ we want a proper fix for this, something like prefixing everything
> > with e.g. get_rl_vlc_ or shorter grv_ should be quite reliable, but
> > uglify the code.
> > If a proper fix is not wanted, then the question is what we would
> > want...
> I was thinking about this on the way in to work. I will gladly submit a
> patch which attempts to provide some crude namespace fixing if I could
> get some advice on what sort of fixing would not be so ugly that it
> wouldn't be accepted.
Forging ahead I have a new patch which changes both GET_VLC and
GET_RL_VLC to have not so easy to clash variables. code_i is just for
mail: erik at hovland.org
PGP/GPG public key available on request
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 2967 bytes
Desc: not available
More information about the ffmpeg-devel