[FFmpeg-devel] FATE & Regressions (and PPC is broken)

Mike Melanson mike
Thu Mar 13 00:30:51 CET 2008

M?ns Rullg?rd wrote:
> Better yet, find out why it breaks on ppc.

Now why didn't I think of that? I'm glad you're on the team. :)

FATE finished its first build/test cycle with the new 'make test' spec.
Here are the other failures:

x86_32/gcc 2.95.3:

--- /home/melanson/ffmpeg/ffmpeg-main/tests/ffmpeg.regression.ref
2008-03-07 15:21:41.000000000 -0800
+++ tests/data/vsynth.regression        2008-03-12 15:42:40.000000000 -0700
@@ -82,9 +82,9 @@
 409360 ./tests/data/a-mpeg4-adap.avi
 6ae220d766c44af3bd58e3d2f5aefa8d *./tests/data/mpeg4adv.vsynth.out.yuv
 stddev: 14.15 PSNR:25.10 bytes:7602176
-41b27141442f773eca9ef3d48d8d555a *./tests/data/a-mpeg4-Q.avi
-878264 ./tests/data/a-mpeg4-Q.avi
-8995abbcc97ed4767fcbc0bf46accd01 *./tests/data/mpeg4adv.vsynth.out.yuv
+660b43204789239fc770abf981bc547f *./tests/data/a-mpeg4-Q.avi
+878092 ./tests/data/a-mpeg4-Q.avi
+3d092069a9f525cd8a64557884fd34a8 *./tests/data/mpeg4adv.vsynth.out.yuv
 stddev:  5.61 PSNR:33.13 bytes:7602176
 6271c9f3b8a6ec3a78315699952d9a99 *./tests/data/a-mpeg4-thread.avi
 778604 ./tests/data/a-mpeg4-thread.avi
make: *** [codectest] Error 1


This is weird; if I build icc and then run 'make test', it crashes here
(tried twice with a 'make clean' in between):

"/home/melanson/ffmpeg/build-icc"/tests/audiogen tests/asynth1.sw
Segmentation fault (core dumped)
make: *** [tests/asynth1.sw] Error 139

But if I run 'make test' again, the process gets to here:

"/home/melanson/ffmpeg/ffmpeg-main"/tests/regression.sh regtest-ffv1
vsynth   tests/vsynth1 a
./ffmpeg_g -y -flags +bitexact -dct fastint -idct simple -y -strict -2
-f image2 -vcodec pgmyuv -i tests/vsynth1/%02d.pgm -an -vcodec ffv1
FFmpeg version SVN-r12422, Copyright (c) 2000-2008 Fabrice Bellard, et al.
  configuration: --cc=ccache /opt/intel/cc/10.1.012/bin/icc
  libavutil version: 49.6.0
  libavcodec version: 51.51.0
  libavformat version: 52.9.0
  libavdevice version: 52.0.0
  built on Mar 12 2008 15:54:37, gcc: Intel(R) C++ gcc 4.1 mode
    Stream #0.0: Video: pgmyuv, yuv420p, 352x288, 25.00 tb(r)
    Stream #0.0: Video: ffv1, yuv420p, 352x288, q=2-31, 200 kb/s, 25.00
./ffmpeg_g -y -flags +bitexact -dct fastint -idct simple -y -i
./tests/data/a-ffv1.avi -f rawvideo ./tests/data/ffv1.vsynth.out.yuv
make: *** [regtest-ffv1] Error 139

x86_64/gcc svn 133010 (new 4.4 devel branch):

diff -u -w
--- /home/melanson/ffmpeg/ffmpeg-main/tests/ffmpeg.regression.ref
2008-03-12 16:14:16.000000000 -0700
+++ tests/data/vsynth.regression        2008-03-12 16:25:33.000000000 -0700
@@ -138,12 +138,12 @@
 2654678 ./tests/data/a-ffv1.avi
 799d3db687f6cdd7a837ec156efc171f *./tests/data/ffv1.vsynth.out.yuv
 stddev:  0.00 PSNR:99.99 bytes:7602176
-5b3430252fdbbc7de5ffedc36150b0bf *./tests/data/a-snow.avi
-156726 ./tests/data/a-snow.avi
-3de2b39f90fd8331f27e627e68e076f7 *./tests/data/snow.vsynth.out.yuv
-stddev: 23.15 PSNR:20.83 bytes:7602176
-c7397d2ceb420f7564dcc785948bff84 *./tests/data/a-snow53.avi
-3520692 ./tests/data/a-snow53.avi
+0f47a1685cdcfaf6ddfb59678922e5a3 *./tests/data/a-snow.avi
+926654 ./tests/data/a-snow.avi
+003d530b500df54621d8ad7238d39a5f *./tests/data/snow.vsynth.out.yuv
+stddev: 26.31 PSNR:19.72 bytes:7602176
+8000127c115f043d074fc17362122759 *./tests/data/a-snow53.avi
+3520822 ./tests/data/a-snow53.avi
 799d3db687f6cdd7a837ec156efc171f *./tests/data/snowll.vsynth.out.yuv
 stddev:  0.00 PSNR:99.99 bytes:7602176
 c299f64c3e85b928c5bfe71629cee006 *./tests/data/a-dv.dv
make: *** [codectest] Error 1

I see that gcc 4.3.0 is available now. I am building that on all
platforms now. I sure hope that works out.

	-Mike Melanson

More information about the ffmpeg-devel mailing list