[FFmpeg-devel] build problems on OpenBSD

Jacob Meuser jakemsr
Wed May 28 06:33:27 CEST 2008


I'm having some problems building recent ffmpeg svn versions.  in fact,
I can't even get started :(

here's what happens with a clean checkout:

acer:~/tmp/ffmpeg-svn-20080527% ./configure
nm: unknown option -- P
usage: nm [-aCegnoprsuVw] [file ...]
od: unknown option -- A
od: od(1) has been deprecated for hexdump(1).
usage: od [-aBbcDdeFfHhIiLlOovXx] [-j offset] [-N length] [-t type_string]
        [[+]offset[.][Bb]] [file ...]

[normal display of what configure decides will be built]

Creating config.mak and config.h...
acer:~/tmp/ffmpeg-svn-20080527% gmake
gmake: *** virtual memory exhausted.  Stop.

the problems with nm and od I can work around (I think I did the right
thing, anyway), but even after I get that taken care of, I can't get
past the 'gmake: *** virtual memory exhausted' problem.  I really don't
think this is the result of a broken gmake, as it works for everything
else I've tried.  it's also the "official" OpenBSD gmake package and
there are no open bug reports against it.

any clues?  is it possible the RULES section of subdir.mak makes
gmake want to use a rather large stack?  here is the output of
ulimit -a from the shell:

acer:~/tmp/ffmpeg-svn-20080527% ulimit -a 
time(cpu-seconds)    unlimited
file(blocks)         unlimited
coredump(blocks)     unlimited
data(kbytes)         524288
stack(kbytes)        8192
lockedmem(kbytes)    524288
memory(kbytes)       524288
nofiles(descriptors) 128
processes            128

this is the first time I've tried to update ffmpeg in a while.  I did not
have this problem with ffmpeg from January.

jakemsr at sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

More information about the ffmpeg-devel mailing list