[FFmpeg-devel] different output in threaded code - linux vs mingw

Ramiro Polla ramiro.polla
Tue Oct 7 14:28:12 CEST 2008


On Tue, Oct 7, 2008 at 1:54 AM, Gianluigi Tiesi <mplayer at netfarm.it> wrote:
> On Mon, Oct 06, 2008 at 10:31:59PM -0300, Ramiro Polla wrote:
>> Hi,
>> On Mon, Oct 6, 2008 at 10:24 PM, Gianluigi Tiesi <mplayer at netfarm.it> wrote:
>> > Hi all,
>> > I'm playing with make test, and I have found a non deterministic
>> > output in threaded code on mingw.
>> >
>> > I run:
>> > ./ffmpeg_g -y -flags +bitexact -dct fastint -idct simple -sws_flags
>> > +accurate_rnd+bitexact -b 500k -flags +mv4+part+aic -trellis 1 -mbd bits
>> > -ps 200 -bf 2 -f image2 -vcodec pgmyuv -i tests/vsynth2/%02d.pgm -an
>> > -vcodec mpeg4 -threads 2 ./tests/data/a-mpeg4-thread.avi
>> I think this is just good old issue517 [0]
>> It fails in the mpeg2-thread test as well, doesn't it?
>> > and I get different outputs on mingw at each run, while
>> > the output is always the same on linux.
>> That's odd. I never tried this test on a multiple core machine on
>> Windows, but I've always been able to reproduce it in Linux (and I can
>> no longer test since I'm now using virtualbox with no multiple core
>> virtualization).
> So it's not a win32 only related?


> it depends by multi core ?


> I'm using amd64 x2 on win32 and a single core for linux tests

There you go...

> The visual output of the mt encoding looks ok.

Yeah, Michael said it on one of the many links in the bug report that
there was no problem in the quality.

Ramiro Polla

More information about the ffmpeg-devel mailing list