[FFmpeg-devel] Google Summer of Code participation

Ronald S. Bultje rsbultje
Tue Apr 7 23:04:10 CEST 2009


On Tue, Apr 7, 2009 at 4:58 PM, Thilo Borgmann
<thilo.borgmann at googlemail.com> wrote:
> But I think it would make sense to create a new function
> "try_decode_frame2()" in the same way as for avcodec_decode_video() because
> it is parameterized with a pointer to the buffer and an int for the size,
> but it should be called using an AVPacket struct instead. What do you think?

Michael may be better at answering here, but it's static to utils.c,
so no need for a new function, just change the prototype and update
the callers accordingly.


More information about the ffmpeg-devel mailing list