[FFmpeg-devel] Google Summer of Code participation

Thilo Borgmann thilo.borgmann
Tue Apr 7 23:32:36 CEST 2009

Ronald S. Bultje schrieb:
>> But I think it would make sense to create a new function
>> "try_decode_frame2()" in the same way as for avcodec_decode_video() because
>> it is parameterized with a pointer to the buffer and an int for the size,
>> but it should be called using an AVPacket struct instead. What do you think?
> Michael may be better at answering here, but it's static to utils.c,
> so no need for a new function, just change the prototype and update
> the callers accordingly.
Ok, I got the api-example.c, ffplay.c and ffmpeg.c redone for revision 1 
of the api changes patch.
As it is static seems to be a good reason not go the long way, ok.

Revision 1 attached.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: tb.APICalls.rev1.patch
Type: text/x-patch
Size: 12651 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20090407/42592334/attachment.bin>

More information about the ffmpeg-devel mailing list