[FFmpeg-devel] [PATCH] Rename flush_put_bits() to put_bits_flush()

Måns Rullgård mans
Fri Apr 10 19:53:22 CEST 2009

Michael Niedermayer <michaelni at gmx.at> writes:

> On Fri, Apr 10, 2009 at 05:22:23PM +0200, Stefano Sabatini wrote:
>> Hi all,
>> the new name is consistent with the name for which a function should
>> be prefixed (rather than suffixed) by a prefix telling the namespace
>> to which it applyies, it is also consistent with all the other
>> put_bits_* functions and more grep-friendly.
> iam rather used to flush_put_bits() so iam mildly against the rename
> that is unless several other devels want the rename

All the other functions are put_bits_*, and we have get_bits_*.  I'm
in favour of renaming it to keep things consistent.

M?ns Rullg?rd
mans at mansr.com

More information about the ffmpeg-devel mailing list