[FFmpeg-devel] [PATCH] connect AVCodecContext.rtp_payload_size to x264_params_t.i_slice_max_size
Erik Slagter
erik
Mon Dec 7 20:46:21 CET 2009
On 06-12-09 21:50, Michael Niedermayer wrote:
> On Fri, Dec 04, 2009 at 12:34:52PM -0800, Jason Garrett-Glaser wrote:
>>>>> i_slice_max_size; /* Max size per slice in bytes; includes estimated
>>>> This is probably the one that I've seen the most requests for.
>>>
>> I recall there's a similar field that is used for H.263, but I'm not
>> sure of its name.
>
> AVCodecContext.rtp_payload_size
>
> poor name, i know, could be changed in the next major bump if someone
> sends a patch ...
How about this to start with:
Index: libavcodec/libx264.c
===================================================================
--- libavcodec/libx264.c (revision 20760)
+++ libavcodec/libx264.c (working copy)
@@ -278,6 +279,7 @@
x4->params.i_threads = avctx->thread_count;
x4->params.b_interlaced = avctx->flags & CODEC_FLAG_INTERLACED_DCT;
+ x4->params.i_slice_max_size = avctx->rtp_payload_size;
if (avctx->flags & CODEC_FLAG_GLOBAL_HEADER)
x4->params.b_repeat_headers = 0;
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: diff.txt
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20091207/3a149ec1/attachment.txt>
More information about the ffmpeg-devel
mailing list