[FFmpeg-devel] [PATCH] Rename input/outdev symbols in libavdevice
Thu Jul 2 23:12:23 CEST 2009
On Wed, Jul 01, 2009 at 10:17:36PM +0200, Stefano Sabatini wrote:
> On date Wednesday 2009-07-01 12:51:24 +0200, Michael Niedermayer encoded:
> > On Wed, Jul 01, 2009 at 01:07:20AM +0200, Stefano Sabatini wrote:
> > > On date Monday 2009-06-29 22:01:02 +0200, Stefano Sabatini encoded:
> > > > On date Monday 2009-06-29 21:13:36 +0200, Luca Abeni encoded:
> > > > > Hi,
> > > > >
> > > > > Stefano Sabatini wrote:
> > > > >> Hi, as in subject.
> > > > >
> > > > > Not that I care, but I think this was proposed when
> > > > > libavdevice has been created, but it was rejected.
> > > >
> > > > Do you remember the reasons for which it was rejected?
> > > >
> > > > Appears to me a quite natural change...
> > >
> > > Ping.
> > i for one do not remember why such a change was rejected in the past if it
> > was so ...
> Uh, after some digging in the archive I found this:
> |> Which renames? If it is about the format registration I disagree,
> |> calling the input/output devices (de)muxers is suboptimal.
> |they ARE (de)muxers, implement them as URLProtocol if you like but
> |as long as they are demuxers they should be called demuxers
> Yet I can't figure this out, as for me they just look like devices...
what about indev_demuxer and such ?
Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB
The greatest way to live with honor in this world is to be what we pretend
to be. -- Socrates
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: Digital signature
More information about the ffmpeg-devel