[FFmpeg-devel] [PATCH] Add DPX decoder

Jimmy Christensen jimmy
Thu May 7 08:42:47 CEST 2009


On 2009-05-06 17:12, Benjamin Larsson wrote:
> Jimmy Christensen wrote:
>>
>> + char endian = 0x0;
>
> I'd prefer an int for this flag.
>

Will change it. Just wanted to save the extra unnecessary byte. :)

>> +
>> + magic_num = AV_RB32(headerBuffer);
>> + headerBuffer += 4;
>> + // Check if the files "magic number" is "SDPX" which means it uses
>> big endian or XPDS which is for little endian files
>> + if (magic_num == 0x53445058)
>
> MKTAG('S', 'D', 'P', 'X') instead of 0x53445058.
>
>
> I would do like this to do some error handling also:
>
> if (SDPX)
> endian=1
> else if (XPDS)
> endian=2
> else
> av_log("DPX marker not found")
> return -1
>

Good idea, will implement that instead.

>
> MvH
> Benjamin Larsson
>
>
> _______________________________________________
> ffmpeg-devel mailing list
> ffmpeg-devel at mplayerhq.hu
> https://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-devel




More information about the ffmpeg-devel mailing list