[FFmpeg-devel] [PATCH] Add RTP hinting to the mov muxer

Baptiste Coudurier baptiste.coudurier
Thu Apr 22 10:24:27 CEST 2010


On 4/22/10 12:22 AM, Martin Storsj? wrote:
> On Tue, 20 Apr 2010, Martin Storsj? wrote:
>
>> As discussed, here's the first attempt at adding RTP hinting in the mov
>> muxer.
>
> Here's a rerolled series, only parts 0005 and 0008 are updated. Changes in
> those parts are: Quite a bit of code cleanup, code documentation, smaller
> memory usage, much documentation of the heuristic matching.
>
> Baptiste, are you ok with this from the mov muxer perspective?

Well, can you please merge the patches related to the muxer ?
It's hard for me to review all the separated changes.

Also I find MKTAG('a','b','c','d') without the spaces between the ','
easier to read.

The tref atom function should be mov_write_tref_tag, MOVTrack should 
contain tref_id and tref_tag to make it generic because it is used for 
chapters as well.

Also the code writing stss atom should be generic, ie not dependent of 
the source track being a video track. Either the track has keyframes or 
only keyframes, the current code should behave correctly and the 
condition should be basically: tag == "rtp " || codec == VIDEO

Also the hint_track and src_track fields confuses me, either it is an 
index or a track, but I'm tired atm ;)

Finally, do use av_new_stream for the hint tracks, add them internally, 
this will have side effects on the interleaving when muxing.

[...]

-- 
Baptiste COUDURIER
Key fingerprint                 8D77134D20CC9220201FC5DB0AC9325C5C1ABAAA
FFmpeg maintainer                                  http://www.ffmpeg.org



More information about the ffmpeg-devel mailing list