[FFmpeg-devel] AAC decoder corrups memory?

Pavel Pavlov pavel
Wed Mar 17 12:08:02 CET 2010

> On 17 March 2010 10:35, Pavel Pavlov <pavel at summit-tech.ca> wrote:
> > I didn't try to play clips with aac sound for a while and wanted to
> try some clips from IPone (that contain aac sound) and I'm constantly
> getting crashes. These crashes happen because of memory corruption and
> malloc returns 0 (I see debug messages about heap corruption). All that
> happens before even it starts to play anything, sometimes even before
> av_find_stream_info returns. I tried to debug, and I see that
> av_find_stream_info internally opens aac decoder. I tried to play
> different files, no problem, but If I play files with aac it always
> crashes. I disable aac decoder and recompiled ffmpeg and now it doesn't
> crash.
> > Simply dropping a file with aac sound to ffplay crashes it before it
> even starts playing. Anyone has the same behavior? Seems that it was
> affected by some recent changes, the same movies that I'm trying to
> play used to play fine before
> http://ffmpeg.org/bugreports.html
> And please provide a sample with which you can reproduce the issue.

Considering that it fails before even trying to read packets I guess anything that contains aac will have the same effect.

More information about the ffmpeg-devel mailing list