[FFmpeg-devel] Operation not permitted when reading RTSP stream

Martin Storsjö martin
Wed Jan 26 16:18:36 CET 2011

On Mon, 24 Jan 2011, Stas Oskin wrote:

> Trying to save / re-stream video via ffmpeg binary produces the following
> error:
> [rtp @ 0x1d16ee30] pts < dts in stream 0
> av_interleaved_write_frame(): Operation not permitted
> It seems as the presentation time arrives earlier then decoder time, which
> causes this error. I tried passing the igndts and genpts flags, but with
> same result.
> In my code I'm ignoring this situation and just using the PTS, which might
> be the reason why it works out for me only for the decoding.

Hmm, there are a number of different issues like this, I'm not exactly 
sure which one of the cases this is. If you receive over UDP, try setting 
-max_delay 500000 before the input url, in order to enable RTP packet 
reordering, which might or might not help.

This might also be related to these issues: 
But since roundup doesn't seem to be working too well at the moment, I 
can't really check what error messages were shown in thoses cases.

// Martin

More information about the ffmpeg-devel mailing list