[FFmpeg-devel] [FFmpeg-commits] os: replace select with poll

Luca Barbato lu_zero
Fri Jan 28 18:41:41 CET 2011

On 01/28/2011 05:12 PM, Ronald S. Bultje wrote:
> "p" in a struct sucks, can you rename it to something a little bigger?

Sure. poll_array sounds good?

> Also, you only updated the UDP code to use this, but allocate it for
> TCP also, can you either not allocate it or use it for TCP also?

Probably we could do better to avoid the double poll (before double select).



Luca Barbato

More information about the ffmpeg-devel mailing list