[FFmpeg-devel] [PATCH] mp: extend syntax, make it accept mp=filter=params

Stefano Sabatini stefano.sabatini-lala at poste.it
Mon Mar 28 00:15:28 CEST 2011


Make the mp wrapper accept the syntax mp=filter=params as alternative
to mp=filter:params. The alternative syntax is sligthly more readable
and should simplify the copy&paste of MPlayer filter strings to the mp
filter.
---
 libavfilter/vf_mp.c |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/libavfilter/vf_mp.c b/libavfilter/vf_mp.c
index 484572c..374acac 100644
--- a/libavfilter/vf_mp.c
+++ b/libavfilter/vf_mp.c
@@ -739,7 +739,7 @@ static av_cold int init(AVFilterContext *ctx, const char *args, void *opaque)
 
     m->avfctx= ctx;
 
-    if(!args || 1!=sscanf(args, "%255[^:]", name)){
+    if(!args || 1!=sscanf(args, "%255[^:=]", name)){
         av_log(ctx, AV_LOG_ERROR, "Invalid parameter.\n");
         return AVERROR(EINVAL);
     }
-- 
1.7.2.3




More information about the ffmpeg-devel mailing list