[FFmpeg-devel] can't get it to work on CentOS

Matteo Sisti Sette matteosistisette at gmail.com
Mon May 23 22:14:34 CEST 2011


I need help to get ffmpeg to work on a CentOS server.
I can't understand why it has to be so difficult.

I first tried installing it with yum:
yum install ffmpeg

but when I tried to convert some amr files to mp3 I got this error:

[amrnb @ 0x626e90] dtx mode not implemented. Update your FFmpeg version 
to the newest one from SVN. If the problem still occurs, it means that 
your file has a feature which has not been implemented.If you want to 
help, upload a sample of this file to 
ftp://upload.ffmpeg.org/MPlayer/incoming/ and contact the ffmpeg-devel 
mailing list.

repeated a lot of times.

That didn't make much sense, because on another CentOS box I have a 
version of ffmpeg that a friend of mine compiled several years ago which 
can decode the same files without any issue (and so does the version for 
ubuntu that I got with apt get on yet another box).

However I thought the package from the repository must be outdated and 
hence I followed the instructions I found here

getting the latest version from SVN and compiling it from scratch.

After all that work, I got it compiled and installed but I get exactly 
the same error when trying to decode amr audio files.

My guess is that the error message is a bogus error message that has 
nothing to do with the real issue, otherwise it doesn't make any sense 
that a feature that is implemenented in a several-year-old version is 
not in the latest one.

Can anybody help me to get ffmpeg to work properly on CentOS with 
support for at least:
- decoding amr files
- encoding mp3 files
- decoding 3gp files
- encoding flv and h264 files
(or better, just all existing codecs on earth)

Thanks in advance

More information about the ffmpeg-devel mailing list