[FFmpeg-devel] [PATCH 1/5] lavu: add av_dynarray_alloc_elem().

Stefano Sabatini stefasab at gmail.com
Fri May 10 18:30:14 CEST 2013

On date Friday 2013-05-10 18:16:59 +0200, Clément Bœsch encoded:
> On Fri, May 10, 2013 at 10:26:13AM +0200, Stefano Sabatini wrote:
> [...]
> > Updated. If someone has an idea about a better name
> > (av_dynarray_alloc_elem() doesn't match very well with
> > av_dynarray_add()), please tell.
> > 
> Well, they don't work on the same type of array, they are in a sense
> "incompatible", so I think the names are even too close.

What about:
void *av_dynbuf_add(void **tab_ptr, int *nb_ptr, char *buf, size_t buf_size)

which prepends the content of buf to the dynamic buffer, or extends
the size in case buf is NULL.

This should be even handier for my specific use case. Consider the
patch suspended for the moment since I need to experiment a bit with
FFmpeg = Fascinating and Fast Majestic Peaceful Exploitable Guru

More information about the ffmpeg-devel mailing list