[FFmpeg-devel] [PATCH] lavfi/geq: use more generic names for internal functions

Michael Niedermayer michaelni at gmx.at
Mon May 20 13:19:49 CEST 2013


On Mon, May 20, 2013 at 11:40:58AM +0200, Stefano Sabatini wrote:
> ---
>  libavfilter/vf_geq.c |   12 ++++++------
>  1 file changed, 6 insertions(+), 6 deletions(-)
> 
> diff --git a/libavfilter/vf_geq.c b/libavfilter/vf_geq.c
> index 70bcdbe..64f651b 100644
> --- a/libavfilter/vf_geq.c
> +++ b/libavfilter/vf_geq.c
> @@ -92,10 +92,10 @@ static inline double getpix(void *priv, double x, double y, int plane)
>  
>  //TODO: cubic interpolate
>  //TODO: keep the last few frames
> -static double lum(void *priv, double x, double y) { return getpix(priv, x, y, 0); }
> -static double  cb(void *priv, double x, double y) { return getpix(priv, x, y, 1); }
> -static double  cr(void *priv, double x, double y) { return getpix(priv, x, y, 2); }
> -static double alpha(void *priv, double x, double y) { return getpix(priv, x, y, 3); }
> +static double c0(void *priv, double x, double y) { return getpix(priv, x, y, 0); }
> +static double c1(void *priv, double x, double y) { return getpix(priv, x, y, 1); }
> +static double c2(void *priv, double x, double y) { return getpix(priv, x, y, 2); }
> +static double c3(void *priv, double x, double y) { return getpix(priv, x, y, 3); }

we should provide both rgb & yuv input values independant of the used
output mode
so IMHO this patch moves in the wrong direction

[...]
-- 
Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

Into a blind darkness they enter who follow after the Ignorance,
they as if into a greater darkness enter who devote themselves
to the Knowledge alone. -- Isha Upanishad
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
URL: <http://ffmpeg.org/pipermail/ffmpeg-devel/attachments/20130520/fb7ab8fe/attachment.asc>


More information about the ffmpeg-devel mailing list