[FFmpeg-devel] Merge from ffmpeg 1.1.3 to 2.1.2 port for CE

Hermann, Sven (SCR US) sven.hermann at siemens.com
Wed Jan 29 00:03:21 CET 2014

Thanks for the hint with the list, you might be right.
Well I am fairly certain that the AVPacket is correct since it was working just fine with 1.1.3.  However maybe there are new requirements in 2.1.2 I don't know of and have not set the correct flags?
I also agree with you that even if the packet is corrupted, it should not crash. That's why I thought I choose this list. I kinda suspect the issue somewhere else as well. Looking at h264.c and the said functions, they are not fundamentally different. So I am really on a cross roads here. What to do next?

-----Original Message-----
From: ffmpeg-devel-bounces at ffmpeg.org [mailto:ffmpeg-devel-bounces at ffmpeg.org] On Behalf Of Reimar Döffinger
Sent: Tuesday, January 28, 2014 5:54 PM
To: FFmpeg development discussions and patches
Subject: Re: [FFmpeg-devel] Merge from ffmpeg 1.1.3 to 2.1.2 port for CE

On Tue, Jan 28, 2014 at 09:19:26PM +0000, Hermann, Sven (SCR US) wrote:
> Hi,
> I inherited a project where we have ported a ffmpeg version to Windows CE.
> It is built in Cygwin with MinGW in a quite big process. But that just as background.
> I recently tried to port the new version (2.1.2) to this build process, and have since massive problems with my application.
> The Application is a Video Stream Player for IP Cameras. This means, I don't have to deal with encoding frames or such. My Stream (H264 and MPEG4) is tunneled through live555 and I get a callback with the frame available. Now this frame is sent to ffmpeg to decode.
> With ffmpeg 1.1.3, this worked just fine, and since I ported 2.1.2, I get an crash in a call to avcodec_decode_video2(). I tried to trace this further down. But since I am cross compiling with a terrible Cygwin and Visual Studio setup this is rather painful. However, I could trace it all the way down to decode_nal_units() in h264.c (I am debugging the H264 decoder first).
> On this level I cannot really tell anymore what is going on since I debug ffmpeg with printf() insertions (I know, terrible... but I have no way to actually debug ffmpeg on my ce device).
> I enabled all the traces for this level, and get the following:
> [h264 @ 0xaa320] Unknown NAL code: 0 (0 bits)
> [h264 @ 0xaa320] Unknown NAL code: 0 (1934 bits)

I have some doubts this is the best list, this one seems more
appropriate: https://lists.ffmpeg.org/mailman/listinfo/libav-user/
However the number of errors you get mean that the decoder almost certainly gets broken data.
Are you sure you pass in a valid AVPacket? Either straight from avformat or if manually created after all the necessary stuff like av_init_packet and setting data, size and flags?
(Note that it still should not crash no matter how broken the input data, but maybe if you find the cause of the one it will explain the other) _______________________________________________
ffmpeg-devel mailing list
ffmpeg-devel at ffmpeg.org

This message and any attachments are solely for the use of intended recipients. The information contained herein may include trade secrets, protected health or personal information, privileged or otherwise confidential information. Unauthorized review, forwarding, printing, copying, distributing, or using such information is strictly prohibited and may be unlawful. If you are not an intended recipient, you are hereby notified that you received this email in error, and that any review, dissemination, distribution or copying of this email and any attachment is strictly prohibited. If you have received this email in error, please contact the sender and delete the message and any attachment from your system. Thank you for your cooperation

More information about the ffmpeg-devel mailing list