[FFmpeg-devel] [PATCH] lavfi: rename af_aresample to af_resample

Rostislav Pehlivanov atomnuker at gmail.com
Mon Mar 6 11:08:43 EET 2017

On 6 March 2017 at 09:00, Carl Eugen Hoyos <ceffmpeg at gmail.com> wrote:

> 2017-03-06 9:48 GMT+01:00 Rostislav Pehlivanov <atomnuker at gmail.com>:
> > +AVFilter ff_af_resample = {
> > +    .name          = "resample",
> Why? Do we really need two identical filters with similar name?
> We cannot remove the "aresample" filter that is mentioned
> all over our documentation.
> We did not support he resample filter for several years,
> removing it can't be an issue.
> Carl Eugen
> _______________________________________________
> ffmpeg-devel mailing list
> ffmpeg-devel at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-devel

Yeah, I agree, I'd prefer af_aresample to remain. Most of our filters use
af_a<something> for audio and vf_<something> for video (e.g. af_apad and
I'd be happy with the filename remaining af_aresample and the filter
remaining as af_aresample but also providing af_resample (that is if
there's a real need for it; I don't believe there is but maybe someone can
say there is). I've attached a patch which does that.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-af_aresample-provide-af_resample.patch
Type: text/x-patch
Size: 1165 bytes
Desc: not available
URL: <http://ffmpeg.org/pipermail/ffmpeg-devel/attachments/20170306/ea413c3f/attachment.bin>

More information about the ffmpeg-devel mailing list