[FFmpeg-devel] [PATCH] avutil/tests/lfg.c: added proper normality test

Thomas Turner thomastdt at googlemail.com
Tue Mar 7 10:28:14 EET 2017

On Mar 6, 2017 11:47 PM, "Carl Eugen Hoyos" <ceffmpeg at gmail.com> wrote:

2017-03-07 6:36 GMT+01:00 Thomas Turner <thomastdt at googlemail.com>:
> ./configure command worked without ccache:
> ./configure --enable-debug=3 --arch=x86_32 --target-os=linux
> --extra-cflags=-m32 --extra-ldflags=-m32  --enable-cross-compile
> but after installing the following software packages w/ apt-get:
> apt-get install gcc-multilib g++-mult
> after recompiling and installing ffmpeg and running lfg selftest again,
> test still passes for x86_32 w/ gcc.
> Just to double check the results, i ran the lfg test in a virtual machine
> running 32 bit ubuntu and the test indeed passes.
> So i am unable to reproduce the error on x86_32.

The failure is reproducible with gcc 4.3.6 which we supported so far
(and several not-so-supported versions).

Carl Eugen

I see, well I'm running gcc 4.8.4.

Is ffmpeg is there a way to compile w/ a specific version of gcc, without
having to downgrade?

I've tried "./configure --cc='gcc-4.3.6' " which gives an error. However
"./configure --cc='gcc' " doesn't give an error.

ffmpeg-devel mailing list
ffmpeg-devel at ffmpeg.org

More information about the ffmpeg-devel mailing list