[FFmpeg-devel] [PATCH 1/1] avformat/dashenc: Added configuration to override HTTP User-Agent

Steven Liu lingjiujianke at gmail.com
Mon Nov 20 17:54:47 EET 2017

2017-11-20 23:12 GMT+08:00 Hendrik Leppkes <h.leppkes at gmail.com>:
> On Mon, Nov 20, 2017 at 3:11 PM, Steven Liu <lq at chinaffmpeg.org> wrote:
>>> 在 2017年11月20日,下午10:03,Carl Eugen Hoyos <ceffmpeg at gmail.com> 写道:
>>> 2017-11-20 15:00 GMT+01:00 Steven Liu <lq at chinaffmpeg.org>:
>>>>> 在 2017年11月20日,下午9:03,Carl Eugen Hoyos <ceffmpeg at gmail.com> 写道:
>>>>> 2017-11-20 9:17 GMT+01:00 刘歧 <lq at chinaffmpeg.org>:
>>>>>>>>>> 在 2017年11月20日,15:59,Jeyapal, Karthick <kjeyapal at akamai.com> 写道:
>>>>>>>>> On 11/20/17, 1:01 PM, "刘歧" <lq at chinaffmpeg.org> wrote:
>>>>>>>>> 在 2017年11月8日,17:22,Karthick J <kjeyapal at akamai.com> 写道:
>>>>>>>>> +    { "http_user_agent", "override User-Agent field in HTTP header",
>>>>>>>>> OFFSET(user_agent), AV_OPT_TYPE_STRING, {.str = NULL}, 0, 0, E},
>>>>>>>> What about dash_user_agent? The reason is http_user_agent maybe get
>>>>>>>> mean HTTP Protocol user_agent, but this is used in dashenc.
>>>>>>> I kept http_user_agent to maintain uniformity with hlsenc option.
>>>>>>> http://ffmpeg.org/pipermail/ffmpeg-devel/2017-September/215642.html
>>>>>>> In that way, irrespective of hls or dash output format, http_user_agent
>>>>>>> would apply for both.
>>>>>> that should modify to hls_user_agent too. because that is clarified the option
>>>>>> is used in dash or hls, isn’t it?
>>>>> I consider it a huge advantage for users if options in different modules use
>>>>> the same option name if they do the same thing.
>>>>> Is it possible to create confusion if the options share the same name?
>>> Sorry for the bad wording:
>>> Is it possible for "http_user_agent" to create confusion because options
>>> with this name are used in different demuxers?
>> It’s used for dash, isn’t it clear than http_user_agent? If not use -f dash, just only use http_user_agent, what will happen, I think that will get confusion, because hls have the same name, looks like timeout option.
> If two components have the same option that does exactly the same
> thing, it should also be named the same. Especially if those two
> components are also quite similar - ie. two streaming protocol
> demuxers/muxers.
Ok, i see, then use the previous version  is ok.
> - Hendrik
> _______________________________________________
> ffmpeg-devel mailing list
> ffmpeg-devel at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-devel

More information about the ffmpeg-devel mailing list