[FFmpeg-devel] [PATCH 3/8] avutil/mem: Add av_fast_realloc_array()

Anton Khirnov anton at khirnov.net
Thu Jul 14 11:14:07 EEST 2022

Quoting Andreas Rheinhardt (2022-07-12 16:12:16)
> Anton really dislikes the av_fast_* naming and instead wants this to be
> called av_realloc_array_reuse(). I don't care either way. Any more
> opinions on this (or on the patch itself)?

If people dislike _reuse(), I am open to other reasonable suggestions.
This 'fast' naming sucks because
- it tells you nothing about how this function is "fast"
- it is added at the beginning rather than the end, which is
  against standard namespacing conventions

Anton Khirnov

More information about the ffmpeg-devel mailing list