[FFmpeg-soc] [soc]: r1429 - in libavfilter: avfiltergraphdesc.c avfiltergraphfile.c

Vitor vitor1001 at gmail.com
Tue Nov 6 22:00:16 CET 2007


Bobby Bingham wrote:
> On 11/6/07, vitor <subversion at mplayerhq.hu> wrote:
>> Author: vitor
>> Date: Tue Nov  6 20:28:04 2007
>> New Revision: 1429
>> Log:
>> Rename avfiltergraphdesc.c to more descriptif name avfiltergraphfile.c
> Nooo!
> Once I finished with the colorspace negotiation, I was going to work
> on this a bit.

My idea was to finish that while you worked in the colorspace 
negotiation, so it would be already done when you finish.

> The part that opens and reads from a file needs separated out into a
> new source file so that it can be made optional because it's not
> really the place of the library to be opening files behind the back of
> the calling app.  But I think having this sort of graph description is
> still useful for an app to be able to construct itself to easily
> create a graph.
> So I wanted to split the functions up into a set of functions which
> could create the description from a set of strings.  For example,
> there could be a avfilterdesc_parse_link() or such.  These functions
> would operate only on strings passed to them, and could by used by an
> app to easily create a description.  These would remain in
> avfiltergraphdesc.c

I didn't notice it was intended for that. Maybe changing the comment in 
the header to "Filter graph text description"

> A routine to read a description from a file and run it through these
> parsing functions would be split out to a new file so it could be
> disabled.  For that function, avfiltergraphfile would make more sense.

I agree. I'll revert my changes soon.


More information about the FFmpeg-soc mailing list