[FFmpeg-trac] #609(avformat:new): Hang on reading UDP

FFmpeg trac at avcodec.org
Wed Dec 21 21:01:57 CET 2011

#609: Hang on reading UDP
             Reporter:  Krieger     |                    Owner:
                 Type:  defect      |                   Status:  new
             Priority:  normal      |                Component:  avformat
              Version:  git-master  |               Resolution:
             Keywords:              |               Blocked By:
             Blocking:              |  Reproduced by developer:  0
Analyzed by developer:  0           |

Comment (by brazilbrown):

 Replying to [comment:2 Krieger]:
 > There is buffer_size option for that :)
 Thanks for the help, but buffer_size seems to have no effect. When I use
 the udp//x.x.x.x:x?fifo_size=0, I get a whole lot off decoding errors (but
 no hangs). Adding a buffer_size of 5373952 (18 times the default) to the
 input path didn't change that.

 Do you know if this is a recent bug, or has this been a problem for a
 while? I've tried previous versions of ffmpeg, and still get the same
 error, so I suspect this bug has been a problem for a while.

Ticket URL: <http://ffmpeg.org/trac/ffmpeg/ticket/609#comment:3>
FFmpeg <http://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list