[FFmpeg-trac] #821(undetermined:new): --enable-x11grab doesn't work properly

FFmpeg trac at avcodec.org
Fri Dec 23 09:00:36 CET 2011

#821: --enable-x11grab doesn't work properly
             Reporter:  burek        |                     Type:  defect
               Status:  new          |                 Priority:  normal
            Component:               |                  Version:  git-
  undetermined                       |  master
             Keywords:               |               Blocked By:
             Blocking:               |  Reproduced by developer:  0
Analyzed by developer:  0            |
 I've tried configuring ffmpeg with --enable-x11grab and the configure
 passed without any errors, but x11 input wasn't enabled (I still had the
 message "Unknown input format: 'x11grab'" after the building process and
 even ./configure --enable-x11grab .. | grep x11_grab_device didn't produce
 any output)

 Recommendation is that configure should check if needed libraries are
 installed for x11 input device to be properly built and if they are not
 installed, to break out of the configure process with a descriptive error

 I've solved my problem reading this article:
 which basically says that I lacked some libraries (libx11-dev, libxfixes-
 dev and libxext-dev), and after installing those, I've had x11_grab_device
 in the list of input devices.

Ticket URL: <https://ffmpeg.org/trac/ffmpeg/ticket/821>
FFmpeg <http://ffmpeg.org>
FFmpeg issue tracker

More information about the FFmpeg-trac mailing list